This help center has been deprecated and moved to a new address, please follow this link to open an active help center.

Thank you and sorry for inconvenience!



Follow

JavaScript Debugging/Live Edit: Chrome extension disconnects in a few seconds

The problem might be caused by Chrome update.

Chrome API/protocols changes in versions 37+ have made it incompatible with JetBrains JavaScript debugger. https://youtrack.jetbrains.com/issue/WEB-12418 is fixed in Idea 14 EAP (http://confluence.jetbrains.com/display/IDEADEV/IDEA+14+EAP) and WebStorm 9 EAP (http://confluence.jetbrains.com/display/WI/WebStorm+9+EAP). Fix is also included in WebStorm 8.0.5
If using EAP is not an option for you, try downgrading Chrome to 36.*

Comments

  • Avatar
    m c

    Hi Elena, do you recommend using safari or firefox for debugging?

  • Avatar
    Elena Pogorelova

    Debugging in Safari is not supported. Debugging in FireFox doesn't work after recent FireFox update (same issue as with Chrome - massive API changes). See my recommendations above - either upgrade to WebStorm 9 or 8.0.5 or downgrade Chrome

  • Avatar
    Jay

    What's the recommendation for PyCharm users?

  • Avatar
    Elena Pogorelova
  • Avatar
    Tomas Walch

    I am using PyCharm professional and this answer is not good enough. The product I purchased is breaking and you are not going to fix it in current version?

    Downgrading Chrome in Ubuntu is not that easy -- older packages are not kept in Google's repository. I would if I could find the right package.

  • Avatar
    Anders Larm

    I'm running WebStorm 9.0.1 with Chrome v38.0.2125.111 m, and this issue is still here. I'm on Windows 8.1 with a licensed version of WebStorm. I've tried removing and reinstalling the JB Chrome extension, no dice. Help -> Check for update... tells me I have the latest version of WebStorm installed.

    Any ideas on what I can do to resolve this?

  • Avatar
    Elena Pogorelova

    I don't have problems debugging in Chrome 38.0.2125.111 m with WebStorm 9.0.1, so it must be a different issue. I'd suggest creating a support ticket, attaching your idea.log, Chrome extension console content and screencast that shows up your issue

  • Avatar
    Anders Larm

    Hi again Elena,

    Thanks for the quick reply!

    Uninstalling all older versions of WebStorm (I ran 8, the 9 beta and 9 stable on the same machine) and restarting resolved my issue.

    Debugging is now live with Chrome 38.0.2125.111 m.

  • Avatar
    Henry Pierre

    Hello,

    Will the fix in IntelliJ 14 be back ported to IJ 13 ?

    Thanks

  • Avatar
    Henry Pierre

    Well it seems it was integrated in IDEA 13.1.5. Thanks :)

  • Avatar
    Colby Blair

    This is a big issue for me as well. I've been doing some logging with chrome, but there's a lot of output. Is there some information I can get for you all that would help find the issue?

    Thanks!

  • Avatar
    Jared Wilkin

    I am a pycharm user running 3.4.1, is my only option to use EAP? Something else interesting my colleague who has the same versions of pycharm, chrome and the chrome extension is not experiencing this problem... does that make sense?

Powered by Zendesk